// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"CR.DITO\s*(?:DA)?\s*TUSD\s*KW\s*\-\s*APCEI\s*\d{2}\/\d{4}\s*(?<VlrDApceiCred>[0-9.-]+\,?\d*)").unwrap();
let string = "Junho 2019
0606 DEBITO TUSD KW - APCEI 04/2019 65,16 0,00 0 0,00 0,00 0,00 0,00
0606 DEB. DA TUSD KW-APCEI- N CONS. 04/2019 1,73 0,00 0 0,00 0,00 0,00 0,00
0606 CREDITO DA TUSD KW - APCEI 06/2019 -22.034,82 0,00 0 0,00 0,00 0,00 0,00
0606 CREDITO TUSD KW-APCEI -N CONS. 06/2019 -238,64 0,00 0 0,00 0,00 0,00 0,00
Janeiro 2020
0606 DEBITO TUSD KW - APCEI 11/2019 50,85 0,00 0 0,00 0,00 0,00 0,00
0606 DEB. DA TUSD KW-APCEI- N CONS. 11/2019 0,92 0,00 0 0,00 0,00 0,00 0,00
0606 CREDITO DA TUSD KW - APCEI 01/2020 -22.514,07 0,00 0 0,00 0,00 0,00 0,00
0606 CREDITO TUSD KW-APCEI -N CONS. 01/2020 -404,71 0,00 0 0,00 0,00 0,00 0,00
Abril 2020
0606 DÉBITO TUSD KW-APCEI 02/2020 102,86 0,00 0 0,00 0,00 0,00 0,00
0606 DÉBITO TUSD KW-APCEI - N CONSUMIDA 02/2020 0,92 0,00 0 0,00 0,00 0,00 0,00
0606 CREDITO TUSD KW-APCEI 04/2020 -23.968,26 0,00 0 0,00 0,00 0,00 0,00
0601 Substituição Tributária - Crédito 378.862,670 0,248265 94.058,22 94.058,22 32 30.098,63 0,00 0,00 0,00
0906 Substituição Tributária - Débito 378.862,670 0,248265 -63.959,60 0,00 0 0,00 0,00 0,00 0,00";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}