$re = '/(?<=Day:)\s+\((.+)\)\s+(?=Time:)/m';
$str = 'Day: ( 8 \\\\ 4 \\\\ 2022) Time: (16:29:41) TesterSlot:9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);