import Foundation
let pattern = #"^\w++\W++((?<=\")[\w-]+(?="))\W+((?<=\")[\w-]+(?="))[\S\s]+?(count\W+=.*)[\S\s]+?^}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
resource "aws_iam_role" "my_test_payer_specific_role" {
count = "${(var.payer_account == "380834257621")?1:0}"
name = "my_test_payer_specific_role"
max_session_duration = "7200"
assume_role_policy = "${data.aws_iam_policy_document.my_test_payer_specific_role-policy.json}"
tags = "${var.resources_tags}"
lifecycle {
ignore_changes = [
"permissions_boundary"
]
}
}
resource "aws_iam_role_policy_attachment" "my_test_payer_specific_role-policy-attachment" {
role = "${aws_iam_role.my_test_payer_specific_role.name}"
count = "${(var.payer_account == "380834257621")?1:0}"
policy_arn = "arn:${var.partition}:iam::aws:policy/AdministratorAccess"
}
data "aws_iam_policy_document" "my_test_payer_specific_role-policy" {
count = "${(var.payer_account == "380834257621")?1:0}"
statement {
actions = ["sts:AssumeRole"]
principals {
type = "AWS"
identifiers = ["arn:${var.partition}:iam::${var.payer_account}:root", "arn:${var.partition}:iam::380834257621:root"]
}
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)