package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?sm)(?:\s|^|\(|\[)(#[0-9]+)(?:\s|$|\)|\]|\.|\,(?:\s|$))`)
var str = `#1, #2, #3
#1 #2 #3 #4
(#1)(#2)(#3)
"#1234"
#1234test
testme#3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}