# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[a-zA-z\-]+( )+?=( )+?(:id)( +)?and|and( +)?[a-zA-z\-]+( )+?=( )+?(:id)$|where( )+?[a-zA-z\-]+( )+?=( )+?(:id)$"
test_str = (" id = :id\n"
" id = id\n\n"
"SELECT * FROM A ID IN (select ID from users where id_ec = :id)\n\n"
"select * from users where id = :id and name = :name\n\n"
"select * from users where name = :name and id = :id aNd name = :name\n\n\n"
"select * from users where name = :name and name = :name and id = :id")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.