# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\#(/)_\-\=\!\:]"
test_str = ("#/usr/bin/python3\n"
"from bisect import bisect_right\n\n"
"def binary_search(vector,x):\n"
" i = bisect_right(vector,x)\n"
" if i != len(vector)+1 and vector[i-1] == x:\n"
" return i-1\n"
" return -1\n"
" \n"
"def is_prime(vector,number):\n"
" return 1 if binary_search(vector,number) != -1 else 0 \n"
" \n"
"def prime_vector(num):\n"
" ret = []\n"
" for a in range(2,num+1):\n"
" if a == 2 or a == 3 or a == 5 or a == 7 or a == 11:\n"
" ret.append(a)\n"
" elif a %2 == 0 or a%3 == 0 or a%5 == 0 or a%7==0 or a%11 == 0:\n"
" continue\n"
" else:\n"
" ret.append(a)\n"
" return ret\n"
" \n"
"number = int(input())\n"
"prime = prime_vector(number)\n"
"ret = []\n"
"p = 0\n\n"
"while number:\n"
" if is_prime(prime,number):\n"
" ret.append(number)\n"
" break\n"
" elif number%prime[p] == 0:\n"
" ret.append(prime[p])\n"
" number = int(number / prime[p])\n"
" else:\n"
" p = p + 1\n"
" \n"
"for a in range((len(ret))):\n"
" print(ret[a],end=\" \")\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.