package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+):(\d+)-(\d+):(\d+)`)
var str = `6:00-18:30`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}