package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^([Gg][Ii][Rr] 0[Aa]{2})|((([A-Za-z][0-9]{1,2})|(([A-Za-z][A-Ha-hJ-Yj-y][0-9]{1,2})|(([AZa-z][0-9][A-Za-z])|([A-Za-z][A-Ha-hJ-Yj-y][0-9]?[A-Za-z]))))\s?[0-9][A-Za-z]{2})$`)
var str = `E18NS
m20 5qj
BS3 1JP
bs3 1jp
m5 8wa
m205qj
Bs31JP
sn55aw
sn5 5aw`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}