use strict;
my $str = 'aaa/prt001.prt.1
aaa/prt001.prt.2
aaa/prt001.prt.3
aaa/prt001.prt.4
aaa/prt001.prt.5
aaa/prt001.prt.10
aaa/prt001.asm.1
aaa/prt001.asm.2
aaa/prt001.asm.3
aaa/prt001.txt.10
aaa/prt001.txt.20
aaa/prt001.txt.30
bbb/prt001.prt
bb/prt.001.prt
bb/prt.001.prt.1
bb/prt.001.1
bb/prt.ppp.prt';
my $regex = qr/\.[A-Za-z]+\.\d+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}