re = /Find the "Hello world!" string in the following paragraph:/m
str = 'Lorem ipsum dolor sit amet, Hello Wolrd! consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Hello world! Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit Hello world! anim id est laborum.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end