re = /(?:(\[.+\]*))/
str = '[Description("Editor Text Value"), Category("Data")]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end