package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(go)+`)
var str = `go
gogo
gogogo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}