# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"BN((6(0[0-9]|1[0134]|2[1-9]|3[0-1]))|7(0[68]|1(0|1[A-C])|2([1-4]|5|[7-9])|3[01]))"
test_str = ("BN601\n"
"BN602\n"
"BN603\n"
"BN604\n"
"BN605\n"
"BN606\n"
"BN607\n"
"BN608\n"
"BN609\n"
"BN610\n"
"BN611\n"
"BN612\n"
"BN613\n"
"BN614\n"
"BN615\n"
"BN616\n"
"BN617\n"
"BN618\n"
"BN619\n"
"BN620\n"
"BN621\n"
"BN622\n"
"BN623\n"
"BN624\n"
"BN625\n"
"BN626\n"
"BN627\n"
"BN628\n"
"BN629\n"
"BN630\n"
"BN631\n"
"BN632\n"
"BN701\n"
"BN702\n"
"BN703\n"
"BN704\n"
"BN705\n"
"BN706\n"
"BN707\n"
"BN708\n"
"BN709\n"
"BN710\n"
"BN711\n"
"BN711A\n"
"BN711B\n"
"BN711C\n"
"BN711a\n"
"BN711b\n"
"BN711c\n"
"BN712\n"
"BN713\n"
"BN714\n"
"BN715\n"
"BN716\n"
"BN717\n"
"BN718\n"
"BN719\n"
"BN720\n"
"BN721\n"
"BN722\n"
"BN723\n"
"BN724\n"
"BN725\n"
"BN726\n"
"BN727\n"
"BN728\n"
"BN729\n"
"BN730\n"
"BN731\n"
"BN732\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.