re = /^(?:https?:\/\/)?(?:[^@\/\n]+@)?(?:www\.)?([^:\/\n]+)/im
str = 'https://play.google.com/store/apps/details?id=com.skgames.trafficracer%22
http://mplay.google.co.in/sadfask/asdkfals?dk=10
http://lplay.google.co.in/sadfask/asdkfals?dk=10
http://play.google.co.in/sadfask/asdkfals?dk=10
http://tplay.google.co.in/sadfask/asdkfals?dk=10
http://www.google.co.in/sadfask/asdkfals?dk=10
www.google.co.in/sadfask/asdkfals?dk=10
http://user:pass@google.com/?a=b#asdd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end