package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w*+-(([0-9])+(.[0-9]+)+(.[0-9]+))`)
var str = `release-3.1.0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}