re = /^(?=.*[0-9])(?=.*[!@#$%^&*+<>])[a-zA-Z0-9!@#$%^&*+<>]{8,15}$/m
str = 'himanshubajaj
Himanshu123456789!@#$%^&*+<>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end