package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/([a-zA-Z]{2}-[a-zA-Z]{2})\/cms\/api\/preview([a-zA-Z0-9-_=\/]*)(\?)?(.*)`)
var str = `/en-US/cms/api/preview/pippo/paperino/pluto/minni/amelia#user=Artibani?qui=qua&quo=qui
/en-US/cms/api/preview/pippo/paperino/pluto/minni/amelia#/user=Artibani?qui=qua&quo=qui
/en-US/cms/api/preview/pippo/paperino/pluto/DePaperoni=ricco/amelia/#user/Artibani?qui=qua&quo=qui
/en-US/cms/api/preview/pippo/paperino/pluto/DePaperoni=ricco/amelia/#/user=Artibani?qui=qua&quo=qui
/en-US/cms/api/preview/pippo/pluto23?qua=qui
/en-US/cms/api/preview/pippo-clarabella/EN-us/123???
/en-US/cms/api/preview/pippo/pluto-orazio?
/en-US/cms/api/preview/pippo/pico-archimede/
/en-US/cms/api/preview/pippo/pico/archimede
/en-US/cms/api/preview/pippo/paperino/pluto/minni/amelia#user/Faraci
/en-US/cms/api/preview/pippo/paperino/pluto/minni/amelia/#user=Faraci
/en-US/cms/api/preview
/en-US/cms/api/preview/
/en-US/cms/api/preview?
/en-US/cms/api/preview/?
/en-US/cms/api/preview#user=Artibani?qui=qua&quo=qui&cap_paperopoli=123
/en-US/cms/api/preview/#user/Artibani?qui=qua&quo=qui&cap_paperopoli=123
/en-US/cms/api/preview#/user=Artibani?qui=qua&quo=qui&cap_paperopoli=123
/en-US/cms/api/preview/#/user=Artibani?qui=qua&quo=qui&cap_paperopoli=123
/en-US/cms/api/preview#user=Faraci
/en-US/cms/api/preview#/user=Faraci
/en-US/cms/api/preview/#/user=Faraci
/en-US/cms/api/preview/pippo/paperino/pluto/minni/amelia?qui=qua&quo=qui
/en-US/cms/api/preview/pippo/paperino/pluto/DePaperoni=ricco/paperoga?qui=qua&quo=qui
/en-US/cms/api/preview/pippo/pluto23?qua=qui
/en-US/cms/api/preview/pippo-clarabella/EN-us/123???
/en-US/cms/api/preview/pippo/pluto-orazio?
/en-US/cms/api/preview/pippo/pico-archimede/?
/en-US/cms/api/preview/pippo/pico-archimede/
/en-US/cms/api/preview/pippo/pico/archimede
/en-US/cms/api/preview/pippo/paperino/pluto/minni/amelia#user=Faraci
/en-US/cms/api/preview/pippo/paperino/pluto/minni/amelia/#user/Faraci
/en-US/cms/api/preview/pippo/paperino/pluto/minni/amelia/#/user=Faraci
/en-US/cms/api/preview
/en-US/cms/api/preview/
/en-US/cms/api/preview?
/en-US/cms/api/preview/?
/en-US/cms/api/preview#user=Faraci
/en-US/cms/api/preview/#user/&Faraci
NOT OK
/en-US/cms/api/preview?#user=Faraci
/en-US/cms/api/preview?#/user=Faraci
/en-US/cms/api/preview?/#/user=Faraci
/en-US/cms/api/preview/?#user=Faraci
/en-US/cms/api/preview/?#/user/Faraci
/en-US/cms/api/preview/?/#/user=Faraci
/en-US/cms/api/preview/pippo/paperino/pluto/minni/amelia?qui=qua&quo=qui#userArtibani
/en-US/cms/api/preview/pippo/paperino/pluto/minni/amelia/?qui=qua&quo=qui#user/Artibani
/en-US/cms/api/preview?qui=qua&quo=qui#user/Artibani
/en-US/cms/api/preview/?qui=qua&quo=qui#user=Artibani
/en-US/cms/api/preview?#user=Faraci
/en-US/cms/api/preview/?#user/Faraci
Output for Nginx:
/preview/$2?culture=$1&$4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}