#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)\b(10\.[0-9]{4,}(?:\.[0-9]+)*\/(?:(?![\"&\'])\S)+)\b"
Local $sString = "Herbst, D. M., Griffith, N. R., & Slama, K. M. (2014). Rodeo cowboys: Conforming to masculine norms and help-seeking behaviors for depression. Journal of Rural Mental Health, 38, 20–35. http://dx.doi.org/10.1037/rmh0000008" & @CRLF & _
"" & @CRLF & _
"Herbst, D. M., Griffith, N. R., & Slama, K. M. (2014). Rodeo cowboys: Conforming to masculine norms and help- seeking behaviors for depression. Journal of Rural Mental Health, 38, 20–35. doi:10.1037/rmh0000008" & @CRLF & _
"" & @CRLF & _
"Example: https://doi.org/10.5468/ogs.2016.59.1.1" & @CRLF & _
"" & @CRLF & _
""Quantum tomography: Measured measurement", Markus Aspelmeyer, nature physics January 2009, Volume 5, No 1, pp11-12; [doi:10.10.1038/nphys1170]" & @CRLF & _
"" & @CRLF & _
"Held, Gilbert. Internetworking LANs and WANs (Second Edition), John Wiley & Sons, 1998, Published Online 05 Oct 2001. Chapter 1, Network Concepts (p 1-30) [doi:10.1002/0470841559.ch1]" & @CRLF & _
"" & @CRLF & _
"Irino, T; Tada, R (2009): Chemical and mineral compositions of sediments from ODP Site 127-797. Geological Institute, University of Tokyo. [doi:10.1594/PANGAEA.726855]" & @CRLF & _
"Earthquake Event, Authored by Automated System:" & @CRLF & _
"" & @CRLF & _
"Geofon operator (2009): GEOFON event gfz2009kciu (NW Balkan Region) GeoForschungsZentrum Potsdam(GFZ). [doi:10.1594/GFZ.GEOFON.gfz2009kciu]" & @CRLF & _
"" & @CRLF & _
"Kraus, Stefan; del Valle, Rodolfo (2008): Geological map of Potter Peninsula (King George Island, South Shetland Islands, Antarctic Peninsula). Instituto Antártico Chileno, Punta Arenas, Chile & Instituto Antártico Argentino, Buenos Aires, Argentina. [doi:10.1594/PANGAEA.667386]" & @CRLF & _
"" & @CRLF & _
"B. Kirchhof (2009) Silicone oil bubbles entrapped in the vitreous base during silicone oil removal, Video Journal of Vitreoretinal Surgery. [doi: 10.3207/2959859860]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")