$re = '/^(?:[a-z](?:[a-z0-9]|-(?!$|-))*\:?(?!$))?(?:[a-z](?:[a-z0-9]|-(?!$|-))*(?:\.(?!$))?)+$/m';
$str = 'namespace:key-name.value';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);