const regex = /(?:^| )([a-zA-Z0-9])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^| )([a-zA-Z0-9])', 'gm')
const str = `This Is A Test
another Test
90 more tests
Some 100 More Tests`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);