const regex = /((\/(tests|__tests__)((\/|\/.*\/)[^_][^/]*))|(((\/|\/.*\/)[^_][^/]*)\.(spec|test)))\.[jt]sx?$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\\/(tests|__tests__)((\\\/|\\\/.*\\\/)[^_][^\/]*))|(((\\\/|\\\/.*\\\/)[^_][^\/]*)\\.(spec|test)))\\.[jt]sx?$', 'mg')
const str = `/tests/hello.ts
/tests/chop/_hello.jsx
/tests/yip/_yap/he_llo.jsx
/tests/hello/world.jsx.hi
/__tests__/cool.js
/src/cool/_chop/d_ello.spec.ts
/src/cool/io/hello.test.ts
/src/world/_hello.spec.ts
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}