package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(0|-?[1-9][0-9]{0,5})$`)
var str = `-125345`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}