package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{4}-(0[1-9]|1[0-2])-(0[1-9]|[12]\d|3[01])$`)
var str = `2024-12-13`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}