$re = '/\d{5}-?\d{3}/m';
$str = '12345-123
12345678
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);