re = /(?i)(http|https|ftp|ftps):\/\/\S*\.(exe|hta|htr|scr)(\S*|\b|$)/m
str = 'https://oedginnrrl.execute-api.us-east-1.amazonaws.com/v1/readstatus?MailingID=112129934&Email=jn47w%40nih.gov"
https://oedginnrrl.execute-api.us-east-1.amazonaws.com/v1/readstatus?MailingID=112131410&Email=james.king%40nih.gov"
http://list.nih.gov/cgi-bin/wa.exe?SUBED1=PHS-AD-PHARMACISTS&A=1
https://oedginnrrl.execute-api.us-east-1.amazonaws.com/v1/readstatus?MailingID=112130096&Email=jerry.suls%40nih.gov"
https://web.streamlinevrs.com/pmt_common/d_images/email_186198972.script
http://www.scripps.edu/>
https://oedginnrrl.execute-api.us-east-1.amazonaws.com/v1/readstatus?MailingID=112129882&Email=james.welch%40nih.gov"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end