$re = '/[a-zA-Z0-9\._\-]{1,}@[a-z]{1,}\.[a-z]{2,3}/';
$str = 'greg.quer@gmail.fr';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);