use strict;
my $str = 'https://cdn.nlark.com/yuque/0/2024/png/184438/1725935789441-7fcfe714-3a05-40d8-90b5-62a21ea95695.png
';
my $regex = qr/[^\/]+(?=\.\w+$)\.\w+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}