package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((https|http):\/\/)?(www\.)?`)
var str = `https://vrt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}