re = /^(\d{4})\-(0\d|1[012])\-(0\d|[12]\d|3[01])\s([01]\d|2[0-3]):([0-5]\d):([0-5]\d)$/m
str = '1401-12-04 01:00:00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end