import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\d{4})(-| )(\\d{3})(-| )(\\d{4})|((04|\\+61)(\\d{10}|\\d{9}|\\d{8}))|((04|\\+04|61|\\+61)( |-)(\\d{1})( |-)(\\d{4}|\\d{3})( |-)(\\d{4}|\\d{3})))";
final String string = "regex australian phone number format (e.g. 0412-123-4567) or (e.g. 0412 123 4567) or (e.g. 0412-123 4567) or (e.g. 0412345678) or (e.g. +61 4 1234 5678) or (e.g. +61 4 1234 567) or (e.g. +6101234567) or (e.g. +61012345678)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}