#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s:(<a href="onebook\.php\?novelid=([\d]+?)".*?>(.*?)<\/a>.*?center">(.+?)<.*?center">(.+?)<.*?<td align="right">([\d]+?)<.*?<td align="right">([\d]+?)<\/td>))"
Local $sString = "<table width="986" border="0" align="center" cellpadding="0" cellspacing="0"" & @CRLF & _
" class="cytable">" & @CRLF & _
" <tbody>" & @CRLF & _
" <tr>" & @CRLF & _
" <td width="126" class="sptd">作者</td>" & @CRLF & _
" <td width="278" class="sptd">作品</td>" & @CRLF & _
" <td width="168" class="sptd">类型</td>" & @CRLF & _
" <td width="71" class="sptd">风格</td>" & @CRLF & _
" <td width="63" class="sptd">进度</td>" & @CRLF & _
" <td width="63" class="sptd">字数</td>" & @CRLF & _
" <td width="73" class="sptd">作品积分</td>" & @CRLF & _
" <td width="138" class="sptd">发表时间</td>" & @CRLF & _
" </tr>" & @CRLF & _
" " & @CRLF & _
" <tr>" & @CRLF & _
" <td align="left">" & @CRLF & _
" <a href="oneauthor.php?authorid=385748" target="_blank">君sola</a>" & @CRLF & _
" </td>" & @CRLF & _
" <td align="left">" & @CRLF & _
" <a href="onebook.php?novelid=1473506" target="_blank" title="简介:腹黑冰山美御姐与温柔黑化姑娘 标签:">探虚陵现代篇</a>" & @CRLF & _
" </td>" & @CRLF & _
" <td align="center">" & @CRLF & _
" 原创-百合-近代现代-爱情 </td>" & @CRLF & _
" <td align="center">" & @CRLF & _
" 正剧 </td>" & @CRLF & _
" <td align="center">" & @CRLF & _
" 连载中 </td>" & @CRLF & _
" <td align="right">2996549</td>" & @CRLF & _
" <td align="right">9653954560</td>" & @CRLF & _
" <td align="center">2012-03-21 11:25:31</td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td align="left">" & @CRLF & _
" <a href="oneauthor.php?authorid=1696863" target="_blank">酒暖春深</a>" & @CRLF & _
" </td>" & @CRLF & _
" <td align="left">" & @CRLF & _
" <a href="onebook.php?novelid=4170491" target="_blank" title="简介:为生者权,替死者言 标签:">我亲爱的法医小姐</a>" & @CRLF & _
" </td>" & @CRLF & _
" <td align="center">" & @CRLF & _
" 原创-百合-近代现代-悬疑 </td>" & @CRLF & _
" <td align="center">" & @CRLF & _
" 正剧 </td>" & @CRLF & _
" <td align="center">" & @CRLF & _
" <font color='red'>已完成</font> </td>" & @CRLF & _
" <td align="right">878082</td>" & @CRLF & _
" <td align="right">3881133568</td>" & @CRLF & _
" <td align="center">2019-08-29 20:00:00</td>" & @CRLF & _
" </tr>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")