const regex = /(?<=(?:const\s|var\s|let\s)[^;\n]*)(?=const|var|let)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=(?:const\\s|var\\s|let\\s)[^;\\n]*)(?=const|var|let)', 'g')
const str = `const asd2 = "asd2"
const asd = "asd"; const asd = "asd" {;JUMP;} const`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}