import Foundation
let pattern = #"\b[A-Z][a-z]+\b\s+\b[A-Z][a-z]+\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
54. Mikhail Stepanovich ZUSKO
(Михаил Степанович ЗУСЬКО)
Function: Russian military leader – Lieutenant- General
Chief of staff of the “West” grouping
Former Commander of the 58th Combined Arms Army of the Southern Military District
DOB: 24.5.1972
POB: Vetly, Volyn region, former Ukrainian SSR (now Ukraine)
Nationality: Russian
Gender: male
Associated entities: Ministry of Defence of the Russian Federation
55. Mikhail Yuryevich TEPLINSKIY
(Михаил Юрьевич ТЕПЛИНСКИЙ)
Function: Russian military leader – Colonel-General
Commander of Airborne Forces of the Armed Forces of the Russian Federation
DOB: 9.1.1969
POB: Mospino, Donetsk oblast, former Ukrainian SSR (now Ukraine)
Nationality: Russian
Gender: male
Associated entities: Ministry of Defence of the Russian Federation
56. Nikolay Mikhailovich PARSHIN
(Николай Михайлович ПАРШИН)
Function: Russian military leader – Lieutenant- General
Head of the Main Rocket and Artillery Directorate of the Ministry of Defense of the Russian Federation
DOB: 20.12.1962
POB: The village of Mordovskoye- Kolomasovo, former Mordovian ASSR (now Russian Federation)
Nationality: Russian
Gender: male
Associated entities: Ministry of Defence of the Russian Federation
57. Oleg Yurievich TSOKOV
(Олег Юрьевич ЦОКОВ)
Function: Russian military leader – Major-General
Commander of the 144th Motor Rifle Division of the 20th Combined Arms Army of the Armed Forces of the Russian Federation
DOB: 23.9.1971
POB: former USSR (now Russian Federation)
Nationality: Russian
Gender: male
Associated entities: Ministry of Defence of the Russian Federation
58. Ramil Rakhmatulovich IBATULLIN
(Рамиль Рахматуллович ИБАТУЛЛИН)
Function: Russian military leader – Major-General
Commander of the 90th Guards Tank Division
DOB: 22.10.1976
POB: Bagishevo, Apastovsky District, Tatarstan, former USSR (now Russian Federation)
Nationality: Russian
Gender: male
Associated entities: Ministry of Defence of the Russian Federation
59. Sergey Viktorovich KARAKAEV
(Сергей Викторович КАРАКАЕВ)
Function: Russian military leader – Colonel-General
Commander of the Strategic Missile Forces
DOB: 4.6.1961
POB: The village of Ivano-Slyusarevka, Krasnodar Territory, former USSR (now Russian Federation)
Nationality: Russian
Gender: male
Associated entities: Ministry of Defence of the Russian Federation
SHEN, Weisheng, Zhejiang, China; (a.k.a "Shen shen") DOB 01 Nov 1957; POB Haimen, China; nationality China; Additional Sanctions Information - Subject to Secondary Sanctions; Gender Male; Passport G23381737 (China) issued 13 Jun 2007 expires 12 Jun 2017; National ID No. 330103195711011317 (China) (individual) [NPWMD] [IFSR] (Linked To: ZHEJIANG QINGJI IND. CO., LTD).
WEI, Zunyi (a.k.a. WEI, Zun Yi; a.k.a. "WEI, David"), Beijing, China; DOB 20 Dec 1975; POB Shandong, China; nationality China; Additional Sanctions Information - Subject to Secondary Sanctions; Gender Male; Passport EE1650028 (China) issued 28 Aug 2018 expires 27 Aug 2028; National ID No. 370922197512201811 (China) (individual) [NPWMD] [IFSR] (Linked To: HONG KONG KE.DO INTERNATIONAL TRADE CO., LIMITED).
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)