package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(&[lmnok])(.*?)(&r|$)`)
var str = ` plain &kobfuscated &r&lbold &r&mstrikethrough &r&nunderline &r&oitalic &r&l&mbold-strikethrough &r&lbold &mbold-strikethrough &rplain`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}