import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*((youtu.be\\/)|(v\\/)|(\\/u\\/\\w\\/)|(embed\\/)|(watch\\?))\\??v?=?([^#&?]*).*";
final String string = "https://youtu.be/embed/n-WuWyZPcoE\n"
+ "https://youtube.com/embed/n-WuWyZPcoE\n"
+ "http://www.youtube.com/watch?v=0zM3nApSvMg&feature=feedrec_grec_index\n"
+ "http://www.youtube.com/user/IngridMichaelsonVEVO#p/a/u/1/QdK8U-VIH_o\n"
+ "http://www.youtube.com/v/0zM3nApSvMg?fs=1&hl=en_US&rel=0\n"
+ "http://www.youtube.com/watch?v=0zM3nApSvMg#t=0m10s\n"
+ "http://www.youtube.com/embed/0zM3nApSvMg?rel=0\n"
+ "http://www.youtube.com/watch?v=0zM3nApSvMg\n"
+ "http://youtu.be/0zM3nApSvMg\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}