re = /page\/(\d+)/m
str = '"https://www.normannimmobilier.fr/properties/page/12/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end