$re = '/^local\(\s*([\'"])?\s*([^()]+?)\s*\1?\s*\)$/';
$str = 'local(\'./1.png\')';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);