re = /(?:\p{Extended_Pictographic}[\p{Emoji_Modifier}\p{M}]*(?:\p{Join_Control}\p{Extended_Pictographic}[\p{Emoji_Modifier}\p{M}]*)*|\s|.)\p{M}*/
str = 'f🗿☺⣿🧀f🌚g👨👩👧👦ll🏳️🌈o͂ȩl^^🔥
👨❤️💋👨अनुच्छेद
s👌뎌쉐👌🏽a
s👩💻f🎉ggZ͑ͫ̓ͪ̂ͫ̽͏̴̙̤̞͉͚̯̞̠͍A̴̵̜̰͔ͫ͗͢L̠ͨͧͩ͘G̴̻͈͍͔̹̑͗̎̅͛́Ǫ̵̹̻̝̳͂̌̌͘!͖̬̰̙̗̿̋ͥͥ̂ͣ̐́́͜͞'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end