re = /(?:\bT\s(\w+<T>)\(.*\);|(\w+[<?\w+>?]*\s)(\w+)\b((\s{[get;\|private get;|set;]+)|\(.*\));)/m
str = 'void Something();
int SomethingElse(Parameter parameter);
List<Something> SomethingVeryElse(One one, Two two);
T Get<T>(params object[] args);
IEnumerable<Plugin> Plugins { get; }'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end