package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[(.*)\]`)
var str = `[白標]0.6L-58度白標`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}