$re = '/^[a-zA-ZäöüßÄÖÜẞ]+$/m';
$str = '123word
word123
word';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);