re = /\d*(min-width|max-width):\s*(\d+\s?)(px)/
str = 'all and (min-width: 640px) and (max-width: 1023px)
min-width:640px
@media screen and (max-width: 699px) and (min-width: 520px)
media screen and (min-width: 1001px)
@media screen and (max-width: 699px) and (min-width: 520px), (min-width: 1151px)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end