# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:\+44\s?|0)[1238]\d\s?(?:\d\s?){7,8}$"
test_str = ("# Standard\n"
"01386 444400\n"
"01386444400\n"
"+441386444400\n"
"+44 1386 444400\n"
"+44 1386444400\n\n"
"# 5 Digit\n"
"01386 41204\n"
"0138641204\n"
"+44138641204\n"
"+44 1386 41204\n"
"+44 138641204\n\n"
"# 3 Digit area codes (e.g. London)\n"
"+442074343046\n"
"02074343046\n"
"020 74343046\n"
"020 7434 3046\n\n"
"# 4 Digit area codes (e.g. Leeds)\n"
"+441133971337\n"
"01133971337\n"
"0113 3971337\n\n"
"# Commercial\n"
"08451772266\n"
"0845 1772266\n\n"
"# Mobile number (should not match)\n"
"07999888777\n"
"+447999888777\n"
"07999 888 777\n"
"+44 7999888777\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.