using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(?<tagName>\w+)((>)|(.+?>))(.+?)?<\/\k<tagName>>";
string input = @"<transaction>
<id>6753322</id>
<number region=""Russia"">8-900-000-00-00</number>
<nonattr />
<nonattr></nonattr>
<nonattr>text</nonattr>
<attr id=""1"" />
<attr id=""2""></attr>
<attr id=""3"">text</attr>
<email>
<to>to_example@gmail.com</to>
<from>from_example@gmail.com</from>
<subject>Project discussion</subject>
<body font=""Verdana"">Body message</body>
<date day=""12"" month=""12"" year=""2018""/>
</email>
</transaction>
<number region=""Russia"">8-900-000-00-00</number>
<nonattr></nonattr>
<attr id=""2""></attr>
<body font=""Verdana"">Body message</body>
<email>
<to>to_example@gmail.com</to>
<from>from_example@gmail.com</from>
<subject>Project discussion</subject>
<body font=""Verdana"">Body message</body>
<date day=""12"" month=""12"" year=""2018""/>
</email>
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}