#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(<\w+)(\s*[\w-]+="[^"]+")*(\s*[\w-]+="[^"]+")*(\s*>)|(\w)|(<\/\w+)*(\s*>)"
Local $sString = "<td class="sky" data-toggle="up" id="heaven" >" & @CRLF & _
"<td class="sky" data-toggle="up" id="heaven" >" & @CRLF & _
"<td class="sky" data-toggle="up" id="heaven" >" & @CRLF & _
"" & @CRLF & _
"<td class="sky" data-toggle="up" id="heaven" >" & @CRLF & _
"" & @CRLF & _
"<td class="sky" data-toggle="up" id="heaven" >" & @CRLF & _
"" & @CRLF & _
"<td class="sky" data-toggle="up" id="heaven" >" & @CRLF & _
"<td class="sky" data-toggle="up" id="heaven" >" & @CRLF & _
"<td class="sky" data-toggle="up" id="heaven" >" & @CRLF & _
"" & @CRLF & _
"<a href="#" data-toggle="modal" data-target="xxxx">xxxx</a>" & @CRLF & _
"" & @CRLF & _
"<a href="#"data-target="#available-assistance" data-toggle="modal" data-modal="yeah"></a>" & @CRLF & _
"" & @CRLF & _
"<a href="#"data-target="#available-assistance" data-toggle="modal" data-modal="yeah"></a>" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "$1$4$5$6$7"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)