import Foundation
let pattern = #"([^\t\n]+?)[\t]"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
*Client Number *Lease Code *Suite# Suite Active Flag Space ID Space Type Class Type *Space Start Date *Space End Date Lease Code To Sublet From Sublet Start Sublet End Natural BP Percent Rent Type Lease Year Defined Lease YE Month Sales YE Month Paid In Month Paid In Days Partial Year Included Interim Report Notice Int Notice Ann Billing Cycle Percent Rent Notes Percent Rent Doc Name Percent Rent Page Number Percent Rent Sec Number Offset LL Cost Notes LL Cost Doc Name LL Cost Page Number LL Cost Sec Number Tenant TI Tenant Improvements Allowances Commissions IC Amount OC Broker OC Commissions OC Amount Active Flag Profile ID Headcount Capacity Headcount Actual Percent Rent UDF1 Percent Rent UDF2 Percent Rent UDF3 Percent Rent UDF4 Percent Rent UDF5 Suite Square Footage Sub Suite Index
201700 10471 0827 07/01/2012 06/30/2019 Y 8 0 123
201700 10471 0842 07/01/2012 06/30/2019 Y 8 0 124
201700 10471 0827 07/01/2012 06/30/2019 Y 8 0 123
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""$1"\t"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)