$re = '/#(\w+)\s*(\w+)\s*(\S+)/m';
$str = '#define TEST_MACRO 5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);