package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\\log_(\d+)\\left\((0|-\d+|1|e)\\right\)`)
var str = `\log_4\left(e\right)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}