package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?:$|^|)(red-|blue-|indigo-|cool-gray-|pink-|yellow-|teal-|gray-|orange-|green-|purple-)(50|100|200|300|400|500|600|700|800|900)(?:$|^|)`)
var str = `pink-300 red-400 blue-300 teal-800 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}