$re = '/<\s*div.*?>/';
$str = '<div class="tab1">tabs generator</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);